TEAC CA200 HH 13-1 Card Reader and Windows 7

Tech Supporton December 8th, 200921 Comments

I recently upgraded to Windows 7 Ultimate on my Dell Dimension E520 and after upgrading, realized that my TEAC CA-200 card reader no longer worked properly.  I went to support.dell.com to see if there were any Windows 7 drivers available, and of course they were not.  Luckily, there is a fix.  Read on…

  1. Download the Windows Vista drivers from the Dell Support site. (I only tried this with the 32-bit drivers.)
  2. Extract the drivers to the C:\Dell\Drivers\R176587 folder.
  3. Go to that folder, right-click on Imgr32b.exe and go to Properties.
  4. Click on the Compatibility tab and under Compatibility mode, check “Run this program in compatibility mode for:”  Then choose “Windows Vista (Service Pack 2).”
  5. Click OK.
  6. Now, double-click to run the file and follow the instructions to install.  You must put it into compatibility mode or it will not run. (When I installed, it hung near the end of the install process. I killed the program, and everything still worked fine.
  7. This should do it and everything should be working now.

In my case, it did not work immediately. I had to open up the PC, disconnect the card reader and then reconnect it.  Once I did that it was immediately recognized.

Hope this helps.

21 Responses to “TEAC CA200 HH 13-1 Card Reader and Windows 7”

  1. Alice says:

    Thanks so much. I have the exact same model Dell (e520), and the same problem after upgrading from Vista to Win7. Your “fix” worked perfectly, and now my cardreader shows all the different lettered drives.

  2. Dane says:

    Great — that was a big help. I appreciate it.

  3. Kevin says:

    Thanks for the advice I have a dell XPS 720 and had the same problem that you described after upgrading to WIndows 7 from Vista. After trying your suggestion the card readers show up as drives on the computer again and work normally.

  4. Max Nex says:

    Works like a dream, good suggestion – thanks

  5. Adam says:

    I have Windows 7. In my case, it did not work immediately either, but instead of opening the lid and unplugging the card reader, I shut the computer down completely then powered back on. When it got back to the desktop, the card reader was “properly installed” in device manager and worker properly. So it appears that you can either unplug the card reader and replug, or just power down completely and repower back up like I did.

  6. Diana says:

    I have Windows 7 64 bit version. Downloaded the VISTA 64 bit version and followed your instructions. Worked like a charm. I had to reboot but once I did that … my reader is working just fine.

  7. Dave says:

    Running Win7 64Bit on a Dell XPS710. Works fine, didn’t need to reboot either. Thanks for the advice.

  8. Lasse says:

    Thanks! Worked great after I rebooted my computer.

  9. Les says:

    Thanks very much! i've waited along time for this fix.
    I have a inspiron 530, the file that I finally found Imgr32b.exe in is R166859 and needed to install Vista (Service Pack 1) which was the only one that would recognize the driver. It only shows the specific drive when inserted, in Devices with Removable Storage, where it used to show all of them without inserting any.

    It works and starts Nikon Transfer, I'll take it and smile.

  10. RWCatbrook says:

    Im very glad i found your suggestions.
    Now all my hardware is working properly on Win 7

  11. saeed says:

    thanks it works for me

  12. Patrick Miah says:

    Thanks! Works with 64 bits too!

  13. Tech Jumper says:

    Works like a charm. I wonder why it only works with Vista Service Pack 2 instead of Win 7?

  14. Don says:

    I'm afraid mine did not work. But I have the 19-1 Card Reader. so that may be the problem (though it is still the Teac ca200). I did the exact same, but no luck. I have a Dell XPS 420 and just loaded Win7 64 bit. Any suggestions? And just another note, I got an error when running it in compatibility mode as suggested. Said it was supported. Could only do it under XP (SP3). Any help would be appreciated.

  15. Ready Teddy says:

    Just used this fix and it worked great for me. I had to disconnect power and reboot for the drivers to auto-install. THANKS SO MUCH!!!

  16. Joe says:

    Great fix!!!!!

  17. Ben says:

    I had the same issue on my Dell XPS 200. The card reader did not work after upgrading to Windows 7.
    I just installed the latest TAEC CA200 firmware from Dell support web site (R176603), and everything works fine after upgrading the firmware and restarting the computer. I hope it helps.

  18. Ralph says:

    All I did was disconnect the card reader and then reconnect. All my drives are back!!! Thank you so much!

  19. Tomas says:

    Awesome, this worked great. I installed this card reader from another computer to the one I am using now and was afraid I did it for no reason. Follow the instructions step by step and you should have no problem.

  20. Willy says:

    Hi Folks

    There is a 64bit driver offered from Dell called R176598.
    The *.exe file contains the 64bit Installer Imgr64b.exe.
    Procedure as described above ( Install in Vista Mode)

    Cheers

    Willy

    PS : Still waiting for an”update” from Dell for Windows 7
    & a firmware for the XPS 430 This is…. Dell !

Leave a Reply